summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2023-02-17 14:41:32 +0000
committerChris Liddell <chris.liddell@artifex.com>2023-02-21 16:40:01 +0000
commitbb739c7141769a6ae94f8a7d34c7df5632840775 (patch)
tree142ad1580437ec7f17700869023325f6f19c80b8 /configure.ac
parent682eda59d271ac55754a4499027b7569bcf494bd (diff)
downloadghostpdl-bb739c7141769a6ae94f8a7d34c7df5632840775.tar.gz
Don't link libpaper for the Artifex release
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 752b55785..325ab136f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,6 +189,7 @@ AC_SUBST(SED_EXTENDED_REGEX_OPT)
AC_PROG_RANLIB
#AC_PROG_INSTALL
+AC_PROG_GREP
# If the caller has gives a specific pkg-config to use, then
# use it, and skip the tests.
@@ -223,6 +224,16 @@ if test x"$host" != x"$build" ; then
fi
dnl --------------------------------------------------
+dnl Are we GPL?
+dnl --------------------------------------------------
+
+GPL_CONF=yes
+grep "GPL Ghostscript" $srcdir/base/gscdefs.h &> /dev/null
+if test "$?" != "0" ; then
+ GPL_CONF=no
+fi
+
+dnl --------------------------------------------------
dnl Allow excluding the contributed drivers
dnl --------------------------------------------------
@@ -1084,10 +1095,17 @@ fi
AC_SUBST(HAVE_LIBIDN)
AC_SUBST(UTF8DEVS)
+if test x"$GPL_CONF" = x"yes" ; then
+
dnl Tests for libpaper (to determine system default paper size)
-AC_ARG_WITH([libpaper],
+
+ AC_ARG_WITH([libpaper],
AS_HELP_STRING([--without-libpaper],
[disable libpaper support]))
+else
+ with_libpaper=no
+fi
+
if test x$with_libpaper != xno; then
AC_CHECK_LIB(paper, systempapername, [with_libpaper=yes],
[