summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2021-09-15 13:19:17 +0100
committerChris Liddell <chris.liddell@artifex.com>2021-09-15 13:23:31 +0100
commitc1f7df0aed7277c4223b2910f027dac8735fcfe1 (patch)
treec9e502df03355dcd6edfba8956e6358f3c6e78e4 /configure.ac
parentd14398bc5b232f404b31d75b5c4512b345888ae1 (diff)
downloadghostpdl-c1f7df0aed7277c4223b2910f027dac8735fcfe1.tar.gz
Only try to build gpdf if pcl/pl is available
Since the standalone gpdf is based on the pl API layer, we need to leave it out when only the gs source is available (i.e. gs release archives)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b137278c3..421eafc6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2497,8 +2497,9 @@ if test x"$with_pdf" != x"no" ; then
AC_ARG_WITH([pdf], AS_HELP_STRING([--with-pdf=NAME],
[name of the Ghostpdf executible (if the source is available, ignored otherwise) [[gpdf]]]),
[PDF="$with_pdf"],[PDF='gpdf'])
-
- PDF_TARGET=gpdf
+ if test -f $srcdir/pcl/pl/pl.mak; then
+ PDF_TARGET=gpdf
+ fi
CFLAGS="-DBUILD_PDF=1 -I$srcdir/pdf $CFLAGS"
GPDF_DEV="\$(PDFOBJDIR)\$(D)pdfi.dev"
PDF_MAK="\$(PDFSRCDIR)\$(D)pdf.mak"