summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2019-05-08 13:23:26 +0100
committerChris Liddell <chris.liddell@artifex.com>2019-05-09 15:53:38 +0100
commitd2809b15153eedbbe1bfb43fc259bf674e353f42 (patch)
tree07607550b94580258837c4ba54d8090ae25b882d /configure.ac
parentd0d7b8d3866aecafac3601ebd9b4b5d83f4fbe91 (diff)
downloadghostpdl-d2809b15153eedbbe1bfb43fc259bf674e353f42.tar.gz
Add an (interim) --enable-gpdl configure option
This adds gpdl to the default target list for make. Mainly to get the .so build usable without having edit the makefiles. This will be deprecated when gpdl is always in the default target list.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ed9e581a1..7f3563b12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2016,6 +2016,7 @@ AC_SUBST(XPSROMFS_MAK)
GPDL=no_gpdl
GPDL_TARGET=
+GPDL_TARGET_VAR=
GPDL_MAK="\$(GLSRCDIR)\$(D)stub.mak"
# in order to build gpdl we need the pdls available
@@ -2034,6 +2035,15 @@ AC_SUBST(GPDL)
AC_SUBST(GPDL_TARGET)
AC_SUBST(GPDL_MAK)
+
+AC_ARG_ENABLE([gpdl], AC_HELP_STRING([--enable-gpdl],
+ [Add gpdl to the default make target list]),
+[
+ GPDL_TARGET_VAR="\$(GPDL_TARGET)"
+])
+
+AC_SUBST(GPDL_TARGET_VAR)
+
dnl do we compile the postscript initialization files into Ghostscript?
COMPILE_INITS="1"
AC_ARG_ENABLE([compile-inits], AC_HELP_STRING([--disable-compile-inits],