summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2022-09-01 08:51:20 +0100
committerChris Liddell <chris.liddell@artifex.com>2022-09-01 10:12:05 +0100
commitd65e1bd8a5f8183897d2fb99bf3428217370b645 (patch)
tree0e86e8d53bf5c3b9c95dd8ead98c90fe6ffe82e1 /configure.ac
parent22ed83c9f608b66194aba0453c444f9aa284f9aa (diff)
downloadghostpdl-d65e1bd8a5f8183897d2fb99bf3428217370b645.tar.gz
Make jbig2 and jpx decoders mandatory
When PDF is included.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0e49009e..4f26e27f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2483,6 +2483,14 @@ PDF_MAK="\$(GLSRCDIR)\$(D)stub.mak"
PDFROMFS_MAK="\$(GLSRCDIR)\$(D)stub.mak"
if test x"$with_pdf" != x"no" ; then
+
+ if test x"$JBIG2_DECODER" = x""; then
+ AC_MSG_ERROR([No JBIG2 decoder available, required for PDF support])
+ fi
+ if test x"$JPX_DECODER" = x""; then
+ AC_MSG_ERROR([No JPX/JPEG2000 decoder available, required for PDF support])
+ fi
+
if test -f $srcdir/pdf/pdf.mak; then
AC_ARG_WITH([pdf], AS_HELP_STRING([--with-pdf=NAME],
[name of the Ghostpdf executible (if the source is available, ignored otherwise) [[gpdf]]]),