summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2020-09-16 07:48:47 +0100
committerChris Liddell <chris.liddell@artifex.com>2020-09-16 07:48:47 +0100
commitd9369a388ae987b63d66fdd557f95b0073547846 (patch)
tree12240655131b450c1c89a14c5d4901990ce78aaf /configure.ac
parent24808eae80f0def1aeb7f727980d5e0852d3d0e0 (diff)
downloadghostpdl-d9369a388ae987b63d66fdd557f95b0073547846.tar.gz
Bug 702904: Another fix to check for shared libjpeg/libtiff
We cannot combine shared and not shared libjpeg and libtiff - they either both need to be "local" or both shared, and configure checks that and fails when the two are incompatible. However, that check would fail when either libjpeg or libtiff were not being included at all. Since it is libtiff that is the "problem" for this compatibility, now check if TIFF is included, and if not, skip the check.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e3e662b9a..d6f346b76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1628,7 +1628,7 @@ esac
# Skip this check for the recursive configure call.
# Not relevant for AUX tools.
if test x"$enable_auxtools_only" != x"yes" ; then
- if test x"$SHARE_LIBTIFF" != x"$SHARE_LIBJPEG" ; then
+ if test x"$ENABLETIFF" != x"" && test x"$SHARE_LIBTIFF" != x"$SHARE_LIBJPEG" ; then
AC_MSG_ERROR([Mixing local libtiff with shared libjpeg not supported])
fi
fi