summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2023-02-28 09:33:23 +0000
committerChris Liddell <chris.liddell@artifex.com>2023-03-01 15:15:18 +0000
commitfe0f842da782b097ce13c31fccacce2374ed6d4b (patch)
tree1093ef066a6cca2997389d38710c500ed571ee1c /configure.ac
parente5898e7325f655ada29c252509cbd3db981e72b0 (diff)
downloadghostpdl-fe0f842da782b097ce13c31fccacce2374ed6d4b.tar.gz
Bug 705895: Do not allow --enable-dynamic and --enable-hidden-visibility
The "dynamic" X11 devices rely on accessing symbols that are not part of our "public API", symbols that are "hidden" with --enable-hidden-visibility (now the default). So, in configure, throw an error if --enable-dynamic is used without opting out of hidden symbols (--disable-hidden-visibility).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 325ab136f..2e78ca5ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3148,9 +3148,13 @@ AC_SUBST(FT_HIDDEN_CFLAGS)
AC_SUBST(XML_HIDDEN_CFLAGS)
AC_ARG_ENABLE([dynamic], AS_HELP_STRING([--enable-dynamic],
- [Enable dynamically loaded drivers]),
+ [Enable dynamically loaded drivers (note: this option is deprecated because it is incompatible with hidden symbols - use --disable-hidden-visibility]),
[
if test "x$enable_dynamic" != xno; then
+ if test x"$hide_symbols" = x"yes" ; then
+ AC_MSG_ERROR([Sorry, (deprecated) dynamic driver support not compatible with hidden symbols - use --disable-hidden-visibility])
+ fi
+
case $host in
*-linux*|*-gnu)
INSTALL_SHARED="install-shared"