summaryrefslogtreecommitdiff
path: root/expat/tests/Makefile.am
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2022-10-11 09:42:01 +0100
committerChris Liddell <chris.liddell@artifex.com>2022-10-11 09:46:09 +0100
commit1a6e1deb9350135241c09fae39847575ecd5f1f8 (patch)
tree2ce9c6de22119ffcfcfc232dbc9aaab60a7252a4 /expat/tests/Makefile.am
parentb34b47f964f37fab4f53ca6637604af9fbfe0c24 (diff)
downloadghostpdl-1a6e1deb9350135241c09fae39847575ecd5f1f8.tar.gz
Update expat to 2.4.9
Remove C99 stuff in expat 2.4.9 Squashed commits from expat-2.4.9_port branch.
Diffstat (limited to 'expat/tests/Makefile.am')
-rw-r--r--expat/tests/Makefile.am71
1 files changed, 71 insertions, 0 deletions
diff --git a/expat/tests/Makefile.am b/expat/tests/Makefile.am
new file mode 100644
index 000000000..cb68e11eb
--- /dev/null
+++ b/expat/tests/Makefile.am
@@ -0,0 +1,71 @@
+#
+# __ __ _
+# ___\ \/ /_ __ __ _| |_
+# / _ \\ /| '_ \ / _` | __|
+# | __// \| |_) | (_| | |_
+# \___/_/\_\ .__/ \__,_|\__|
+# |_| XML parser
+#
+# Copyright (c) 2017-2021 Sebastian Pipping <sebastian@pipping.org>
+# Copyright (c) 2017 Rhodri James <rhodri@wildebeest.org.uk>
+# Copyright (c) 2020 Jeffrey Walton <noloader@gmail.com>
+# Licensed under the MIT license:
+#
+# Permission is hereby granted, free of charge, to any person obtaining
+# a copy of this software and associated documentation files (the
+# "Software"), to deal in the Software without restriction, including
+# without limitation the rights to use, copy, modify, merge, publish,
+# distribute, sublicense, and/or sell copies of the Software, and to permit
+# persons to whom the Software is furnished to do so, subject to the
+# following conditions:
+#
+# The above copyright notice and this permission notice shall be included
+# in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN
+# NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
+# DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
+# OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE
+# USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+SUBDIRS = . benchmark
+
+AM_CPPFLAGS = @AM_CPPFLAGS@ -I$(srcdir)/../lib
+
+noinst_LIBRARIES = libruntests.a
+
+check_PROGRAMS = runtests runtestspp
+TESTS = runtests runtestspp
+
+# To support MinGW and Non-MinGW at the same time:
+LOG_DRIVER = $(srcdir)/../test-driver-wrapper.sh
+
+libruntests_a_SOURCES = \
+ chardata.c \
+ structdata.c \
+ memcheck.c \
+ minicheck.c
+
+runtests_SOURCES = \
+ runtests.c
+
+runtestspp_SOURCES = \
+ runtestspp.cpp
+
+runtests_LDADD = libruntests.a ../lib/libexpatinternal.la
+runtestspp_LDADD = libruntests.a ../lib/libexpatinternal.la
+
+runtests_LDFLAGS = @AM_LDFLAGS@ @LIBM@
+runtestspp_LDFLAGS = @AM_LDFLAGS@ @LIBM@
+
+EXTRA_DIST = \
+ chardata.h \
+ structdata.h \
+ minicheck.h \
+ memcheck.h \
+ README.txt \
+ udiffer.py \
+ xmltest.log.expected \
+ xmltest.sh