summaryrefslogtreecommitdiff
path: root/expat/tests/Makefile.am
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2018-03-27 16:16:49 +0100
committerChris Liddell <chris.liddell@artifex.com>2018-03-29 13:44:03 +0100
commitd8a919d4b45097a527f6f39d509b920d285d709b (patch)
treebd3db4ec1afbd17fe1c95d1087e81674e3fd2372 /expat/tests/Makefile.am
parent003c4211a019eb5c4719860f353777e177553490 (diff)
downloadghostpdl-d8a919d4b45097a527f6f39d509b920d285d709b.tar.gz
Update expat to 2.2.5
With a couple of tweaks to base/expat.mak to make it work.
Diffstat (limited to 'expat/tests/Makefile.am')
-rw-r--r--expat/tests/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/expat/tests/Makefile.am b/expat/tests/Makefile.am
new file mode 100644
index 000000000..742ed437d
--- /dev/null
+++ b/expat/tests/Makefile.am
@@ -0,0 +1,66 @@
+#
+# __ __ _
+# ___\ \/ /_ __ __ _| |_
+# / _ \\ /| '_ \ / _` | __|
+# | __// \| |_) | (_| | |_
+# \___/_/\_\ .__/ \__,_|\__|
+# |_| XML parser
+#
+# Copyright (c) 2017 Expat development team
+# Licensed under the MIT license:
+#
+# Permission is hereby granted, free of charge, to any person obtaining
+# a copy of this software and associated documentation files (the
+# "Software"), to deal in the Software without restriction, including
+# without limitation the rights to use, copy, modify, merge, publish,
+# distribute, sublicense, and/or sell copies of the Software, and to permit
+# persons to whom the Software is furnished to do so, subject to the
+# following conditions:
+#
+# The above copyright notice and this permission notice shall be included
+# in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN
+# NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
+# DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
+# OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE
+# USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+SUBDIRS = . benchmark
+
+AM_CPPFLAGS = -I$(srcdir)/../lib
+
+noinst_LIBRARIES = libruntests.a
+
+check_PROGRAMS = runtests runtestspp
+TESTS = runtests runtestspp
+
+# To support MinGW and Non-MinGW at the same time:
+LOG_DRIVER = $(srcdir)/../test-driver-wrapper.sh
+
+libruntests_a_SOURCES = \
+ chardata.c \
+ structdata.c \
+ memcheck.c \
+ minicheck.c
+
+runtests_SOURCES = \
+ runtests.c
+
+runtestspp_SOURCES = \
+ runtestspp.cpp
+
+runtests_LDADD = libruntests.a ../lib/libexpat.la
+runtestspp_LDADD = libruntests.a ../lib/libexpat.la
+
+EXTRA_DIST = \
+ chardata.h \
+ structdata.h \
+ minicheck.h \
+ memcheck.h \
+ README.txt \
+ udiffer.py \
+ xmltest.log.expected \
+ xmltest.sh