summaryrefslogtreecommitdiff
path: root/jpeg/Makefile.am
diff options
context:
space:
mode:
authorSebastian Rasmussen <sebras@gmail.com>2021-06-24 21:32:28 +0200
committerSebastian Rasmussen <sebras@gmail.com>2021-06-25 12:30:30 +0200
commitec55f7888d69a49725afdb5d4eb56130559cabf9 (patch)
tree42144d32837947e98f21f8375397f28639763c6f /jpeg/Makefile.am
parent8d4f4b5e1ab9417e2e3a72b800414eceb5eb6f25 (diff)
downloadghostpdl-ec55f7888d69a49725afdb5d4eb56130559cabf9.tar.gz
Update libjpeg to 9d
Plus re-applying: Bug 697186: Workaround JPEG lib bug. 8dcec8cc076a0cf8350ca7a6ec1d3136812e2a24 Bug 697186: Tweak to previous JPEG fix. dc62c90930512f4b571f68c9110022b234cbd411 Squash MSVC build warning. 8d4f4b5e1ab9417e2e3a72b800414eceb5eb6f25
Diffstat (limited to 'jpeg/Makefile.am')
-rw-r--r--jpeg/Makefile.am22
1 files changed, 12 insertions, 10 deletions
diff --git a/jpeg/Makefile.am b/jpeg/Makefile.am
index be5826034..c477a4452 100644
--- a/jpeg/Makefile.am
+++ b/jpeg/Makefile.am
@@ -39,9 +39,9 @@ MKFILES= configure Makefile.in makefile.ansi makefile.unix makefile.b32 \
makejmak.vc6 makecdep.vc6 makecdsp.vc6 makecmak.vc6 makeddep.vc6 \
makeddsp.vc6 makedmak.vc6 maketdep.vc6 maketdsp.vc6 maketmak.vc6 \
makerdep.vc6 makerdsp.vc6 makermak.vc6 makewdep.vc6 makewdsp.vc6 \
- makewmak.vc6 makejsln.v15 makeasln.v15 makejvcx.v15 makejfil.v15 \
- makecvcx.v15 makecfil.v15 makedvcx.v15 makedfil.v15 maketvcx.v15 \
- maketfil.v15 makervcx.v15 makerfil.v15 makewvcx.v15 makewfil.v15 \
+ makewmak.vc6 makejsln.v16 makeasln.v16 makejvcx.v16 makejfil.v16 \
+ makecvcx.v16 makecfil.v16 makedvcx.v16 makedfil.v16 maketvcx.v16 \
+ maketfil.v16 makervcx.v16 makerfil.v16 makewvcx.v16 makewfil.v16 \
makeproj.mac makcjpeg.st makdjpeg.st makljpeg.st maktjpeg.st \
makefile.manx makefile.sas makefile.mms makefile.vms makvms.opt
@@ -58,8 +58,8 @@ CONFIGUREFILES= config.guess config.sub install-sh ltmain.sh depcomp \
OTHERFILES= jconfig.txt ckconfig.c jmemdosa.asm libjpeg.map libjpeg.pc.in
# Test support files
-TESTFILES= testorig.jpg testimg.ppm testimg.bmp testimg.jpg testprog.jpg \
- testimgp.jpg
+TESTFILES= testorig.jpg testimg.ppm testimg.gif testimg.bmp testimg.jpg \
+ testprog.jpg testimgp.jpg
# libtool libraries to build
lib_LTLIBRARIES = libjpeg.la
@@ -108,8 +108,8 @@ pkgconfigdir = $(libdir)/pkgconfig
nodist_pkgconfig_DATA = libjpeg.pc
# Files to be cleaned
-CLEANFILES = testout.ppm testout.bmp testout.jpg testoutp.ppm testoutp.jpg \
- testoutt.jpg
+CLEANFILES = testout.ppm testout.gif testout.bmp testout.jpg testoutp.ppm \
+ testoutp.jpg testoutt.jpg
# Install jconfig.h
install-data-local:
@@ -124,13 +124,15 @@ uninstall-local:
test: check-local
check-local:
rm -f testout*
- ./djpeg -dct int -ppm -outfile testout.ppm $(srcdir)/testorig.jpg
- ./djpeg -dct int -bmp -colors 256 -outfile testout.bmp $(srcdir)/testorig.jpg
- ./cjpeg -dct int -outfile testout.jpg $(srcdir)/testimg.ppm
+ ./djpeg -dct int -ppm -outfile testout.ppm $(srcdir)/testorig.jpg
+ ./djpeg -dct int -gif -outfile testout.gif $(srcdir)/testorig.jpg
+ ./djpeg -dct int -bmp -colors 256 -outfile testout.bmp $(srcdir)/testorig.jpg
+ ./cjpeg -dct int -outfile testout.jpg $(srcdir)/testimg.ppm
./djpeg -dct int -ppm -outfile testoutp.ppm $(srcdir)/testprog.jpg
./cjpeg -dct int -progressive -opt -outfile testoutp.jpg $(srcdir)/testimg.ppm
./jpegtran -outfile testoutt.jpg $(srcdir)/testprog.jpg
cmp $(srcdir)/testimg.ppm testout.ppm
+ cmp $(srcdir)/testimg.gif testout.gif
cmp $(srcdir)/testimg.bmp testout.bmp
cmp $(srcdir)/testimg.jpg testout.jpg
cmp $(srcdir)/testimg.ppm testoutp.ppm