summaryrefslogtreecommitdiff
path: root/lcms2mt/Makefile.am
diff options
context:
space:
mode:
authorRobin Watts <Robin.Watts@artifex.com>2021-02-17 16:04:27 +0000
committerRobin Watts <Robin.Watts@artifex.com>2021-02-17 16:55:05 +0000
commit82dce7f8f6b5218f7943eadff0f01d0e278850fa (patch)
tree7cd334c4ce1fb378ba535dc172c9957d5a5c3982 /lcms2mt/Makefile.am
parent5882f2d765a9348c6f6e2cc45353a06924930c88 (diff)
downloadghostpdl-82dce7f8f6b5218f7943eadff0f01d0e278850fa.tar.gz
Update lcms2mt to lcms2 2.12.
Diffstat (limited to 'lcms2mt/Makefile.am')
-rw-r--r--lcms2mt/Makefile.am24
1 files changed, 6 insertions, 18 deletions
diff --git a/lcms2mt/Makefile.am b/lcms2mt/Makefile.am
index 4c25794d5..e0ade0821 100644
--- a/lcms2mt/Makefile.am
+++ b/lcms2mt/Makefile.am
@@ -10,8 +10,12 @@ ACLOCAL_AMFLAGS = -I m4
PACKAGE_NAME = @PACKAGE_NAME@
PACKAGE_VERSION = @PACKAGE_VERSION@
+if COND_FASTFLOAT
+ USER_PLUGINS = plugins
+endif
+
# Directories containing Makefiles to 'make'
-SUBDIRS = src include utils/tificc utils/transicc utils/linkicc utils/jpgicc utils/psicc testbed
+SUBDIRS = src include utils/tificc utils/transicc utils/linkicc utils/jpgicc utils/psicc testbed $(USER_PLUGINS)
# Additional files to distribute
EXTRA_DIST = AUTHORS COPYING ChangeLog doc Projects include bin Lib INSTALL README.1ST autogen.sh lcms2.pc.in plugins
@@ -19,11 +23,10 @@ EXTRA_DIST = AUTHORS COPYING ChangeLog doc Projects include bin Lib INSTALL READ
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = lcms2mt.pc
-# Get names of plug-ins in the source package
-PLUGIN_DIRECTORIES = $(sort $(dir $(wildcard plugins/*/)))
# Make sure get rid of VC stuff...
clean-local:
+ rm -rf autom4te.cache
find Projects -name "*.user" | xargs rm -rf
find Projects -name "Release" | xargs rm -rf
find Projects -name "Debug" | xargs rm -rf
@@ -32,19 +35,4 @@ clean-local:
find Projects -name "*.log" | xargs rm -rf
find Projects -name "*.sdf" | xargs rm -rf
find Projects -name "*.opensdf" | xargs rm -rf
- find Projects -name "*.log" | xargs rm -rf
find Projects -name "ipch" | xargs rm -rf
- @for d in $(PLUGIN_DIRECTORIES); do (cd $$d; $(MAKE) clean ); done
-
-# Handle plug-ins
-all-local:
- @for d in $(PLUGIN_DIRECTORIES); do (cd $$d; $(MAKE) $(AM_MAKEFLAGS) all ); done
-
-check-local:
- @for d in $(PLUGIN_DIRECTORIES); do (cd $$d; $(MAKE) $(AM_MAKEFLAGS) check ); done
-
-install-exec-local:
- @for d in $(PLUGIN_DIRECTORIES); do (cd $$d; $(MAKE) $(AM_MAKEFLAGS) install-exec ); done
-
-uninstall-local:
- @for d in $(PLUGIN_DIRECTORIES); do (cd $$d; $(MAKE) $(AM_MAKEFLAGS) uninstall ); done