summaryrefslogtreecommitdiff
path: root/tiff/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tiff/test/Makefile.am')
-rw-r--r--tiff/test/Makefile.am28
1 files changed, 23 insertions, 5 deletions
diff --git a/tiff/test/Makefile.am b/tiff/test/Makefile.am
index 90c2f3d1e..4973b6147 100644
--- a/tiff/test/Makefile.am
+++ b/tiff/test/Makefile.am
@@ -55,7 +55,11 @@ CLEANFILES = test_packbits.tif o-*
if HAVE_JPEG
JPEG_DEPENDENT_CHECK_PROG=raw_decode
JPEG_DEPENDENT_TESTSCRIPTS=\
- tiff2rgba-quad-tile.jpg.sh
+ tiff2rgba-quad-tile.jpg.sh \
+ tiff2rgba-ojpeg_zackthecat_subsamp22_single_strip.sh \
+ tiff2rgba-ojpeg_chewey_subsamp21_multi_strip.sh \
+ tiff2rgba-ojpeg_single_strip_no_rowsperstrip.sh
+
else
JPEG_DEPENDENT_CHECK_PROG=
JPEG_DEPENDENT_TESTSCRIPTS=
@@ -63,8 +67,8 @@ endif
# Executable programs which need to be built in order to support tests
check_PROGRAMS = \
- ascii_tag long_tag short_tag strip_rw rewrite custom_dir \
- defer_strile_loading defer_strile_writing testtypes \
+ ascii_tag long_tag short_tag strip_rw rewrite custom_dir custom_dir_EXIF_231 \
+ rational_precision2double defer_strile_loading defer_strile_writing testtypes \
$(JPEG_DEPENDENT_CHECK_PROG)
# Test scripts to execute
@@ -145,6 +149,8 @@ TESTSCRIPTS = \
tiff2rgba-palette-1c-8b.sh \
tiff2rgba-rgb-3c-16b.sh \
tiff2rgba-rgb-3c-8b.sh \
+ testfax4.sh \
+ testdeflatelaststripextradata.sh \
$(JPEG_DEPENDENT_TESTSCRIPTS)
# This list should contain the references files
@@ -153,7 +159,9 @@ REFFILES = \
refs/o-tiff2ps-EPS1.ps \
refs/o-tiff2ps-PS1.ps \
refs/o-tiff2ps-PS2.ps \
- refs/o-tiff2ps-PS3.ps
+ refs/o-tiff2ps-PS3.ps \
+ refs/o-testfax4.tiff \
+ refs/o-deflate-last-strip-extra-data.tiff
# This list should contain all of the TIFF files in the 'images'
# subdirectory which are intended to be used as input images for
@@ -171,11 +179,17 @@ TIFFIMAGES = \
images/rgb-3c-8b.tiff \
images/quad-tile.jpg.tiff \
images/quad-lzw-compat.tiff \
- images/lzw-single-strip.tiff
+ images/lzw-single-strip.tiff \
+ images/ojpeg_zackthecat_subsamp22_single_strip.tiff \
+ images/ojpeg_chewey_subsamp21_multi_strip.tiff \
+ images/ojpeg_single_strip_no_rowsperstrip.tiff \
+ images/testfax4.tiff \
+ images/deflate-last-strip-extra-data.tiff
PNMIMAGES = \
images/minisblack-1c-8b.pgm \
images/miniswhite-1c-1b.pbm \
+ images/rgb-3c-16b.ppm \
images/rgb-3c-8b.ppm
# This list should include all of the files in the 'images'
@@ -203,6 +217,10 @@ raw_decode_SOURCES = raw_decode.c
raw_decode_LDADD = $(LIBTIFF)
custom_dir_SOURCES = custom_dir.c
custom_dir_LDADD = $(LIBTIFF)
+rational_precision2double_SOURCES = rational_precision2double.c
+rational_precision2double_LDADD = $(LIBTIFF)
+custom_dir_EXIF_231_SOURCES = custom_dir_EXIF_231.c
+custom_dir_EXIF_231_LDADD = $(LIBTIFF)
defer_strile_loading_SOURCES = defer_strile_loading.c
defer_strile_loading_LDADD = $(LIBTIFF)
defer_strile_writing_SOURCES = defer_strile_writing.c