summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2011-10-29 22:22:50 -0400
committerMonty Taylor <mordred@inaugust.com>2011-10-29 22:24:53 -0400
commit1b20aa2df32c24a3919fde328bc55e0cefb0962a (patch)
treefd247899862ab63fc098a62feeda6e8e41d43901 /setup.py
parent04397785dfce0164cb2e48f72f08c62bf4ee1fce (diff)
downloadgit-review-1b20aa2df32c24a3919fde328bc55e0cefb0962a.tar.gz
Replace sphinx manpage with manual one.1.4
If we upload source tarballs to PyPI instead of eggs, then the man pages actually work. However, this means that the installer has to run setup.py. Using sphinx, while slighly nicer from a dev perspective, means we have to then require that people installing git-review also install sphinx, which is a bit overkill given the size of the man page. This change, and a change to the release process of not uploading eggs to PyPI should finall get git review --help to work. Change-Id: I29b07667127a9ec5c241b7e1fc5a3960dd2a6b63
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py38
1 files changed, 1 insertions, 37 deletions
diff --git a/setup.py b/setup.py
index 4ce76be..e550f0e 100755
--- a/setup.py
+++ b/setup.py
@@ -15,9 +15,6 @@
# limitations under the License.
from setuptools import setup
-from distutils.command.build import build
-from setuptools.command.bdist_egg import bdist_egg
-import commands
# version comes from git-review.
savename = __name__
@@ -25,38 +22,6 @@ __name__ = "not-main"
exec(open("git-review", "r"))
__name__ = savename
-
-cmdclass = {}
-
-
-try:
- from sphinx.setup_command import BuildDoc
- class local_build_sphinx(BuildDoc):
- def run(self):
- for builder in ['html', 'man']:
- self.builder = builder
- self.finalize_options()
- BuildDoc.run(self)
- cmdclass['build_sphinx'] = local_build_sphinx
-except:
- pass
-
-
-
-class local_build(build):
- def run(self):
- build.run(self)
- commands.getoutput("sphinx-build -b man -c doc doc/ build/sphinx/man")
-cmdclass['build'] = local_build
-
-
-class local_bdist_egg(bdist_egg):
- def run(self):
- commands.getoutput("sphinx-build -b man -c doc doc/ build/sphinx/man")
- bdist_egg.run(self)
-cmdclass['bdist_egg'] = local_bdist_egg
-
-
setup(
name='git-review',
version=version,
@@ -68,6 +33,5 @@ setup(
author_email='openstack@lists.launchpad.net',
url='http://www.openstack.org',
scripts=['git-review'],
- data_files=[('share/man/man1', ['build/sphinx/man/git-review.1'])],
- cmdclass=cmdclass,
+ data_files=[('share/man/man1', ['git-review.1'])],
)