summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorYuriy Taraday <yorik.sar@gmail.com>2012-05-29 14:23:55 +0400
committerYuriy Taraday <yorik.sar@gmail.com>2012-05-29 14:24:50 +0400
commit27929e5ae2f18cb0fa0de6f3c52a7d81a7cc8f87 (patch)
treed67715f714ac84029f8d926bb29fd37535536104 /setup.py
parent0d92517ce5de05061f401bbaff345a024c44319b (diff)
downloadgit-review-27929e5ae2f18cb0fa0de6f3c52a7d81a7cc8f87.tar.gz
Add Python 3 support.
Since git-review made it to http://py3ksupport.appspot.com/, why don't support Python 3. Change-Id: I75c28e4887ca79e794553758d671c75740849f97
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 33f8328..04a2dec 100755
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ from setuptools.command.install import install
# version comes from git-review.
savename = __name__
__name__ = "not-main"
-exec(open("git-review", "r"))
+exec(open("git-review").read())
__name__ = savename
@@ -40,7 +40,10 @@ setup(
cmdclass=git_review_cmdclass,
description="Tool to submit code to Gerrit",
license='Apache License (2.0)',
- classifiers=["Programming Language :: Python"],
+ classifiers=[
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 3",
+ ],
keywords='git gerrit review',
author='OpenStack, LLC.',
author_email='openstack@lists.launchpad.net',