summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2011-09-25 07:40:45 -0700
committerMonty Taylor <mordred@inaugust.com>2011-09-25 09:16:31 -0700
commit2a78c608358317ee5ffd48560635a8c5783247f2 (patch)
tree3de4fa5820234060d735e0dfc0a6a4986c2d59d5 /setup.py
downloadgit-review-2a78c608358317ee5ffd48560635a8c5783247f2.tar.gz
Ported rfc.sh to a standalone program.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py57
1 files changed, 57 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..c1e58d1
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,57 @@
+#!/usr/bin/python
+# Copyright (c) 2010-2011 OpenStack, LLC.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from setuptools import setup, find_packages
+
+version = '1.0'
+
+cmdclass = {}
+
+# If Sphinx is installed on the box running setup.py,
+# enable setup.py to build the documentation, otherwise,
+# just ignore it
+try:
+ from sphinx.setup_command import BuildDoc
+
+ class local_BuildDoc(BuildDoc):
+ def run(self):
+ for builder in ['html', 'man']:
+ self.builder = builder
+ self.finalize_options()
+ BuildDoc.run(self)
+ cmdclass['build_sphinx'] = local_BuildDoc
+
+except:
+ pass
+
+setup(
+ name='git-review',
+ version=version,
+ description="Tool to submit code to Gerrit",
+ license='Apache License (2.0)',
+ classifiers=["Programming Language :: Python"],
+ keywords='git gerrit review',
+ author='OpenStack, LLC.',
+ author_email='openstack@lists.launchpad.net',
+ url='http://www.openstack.org',
+ include_package_data=True,
+ #packages=find_packages(exclude=['test', 'bin']),
+ scripts=['git-review'],
+ zip_safe=False,
+ cmdclass=cmdclass,
+ install_requires=['setuptools'],
+ test_suite='nose.collector',
+ )