summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-04-01 23:46:36 -0400
committerClark Boylan <clark.boylan@gmail.com>2013-04-04 16:22:14 -0700
commita2219154473c8255110696d7700bb63a7ee5d110 (patch)
tree30932fac0f79bdf771357e41271adf748787e3b8 /setup.py
parent3be868a923615ae74bab3f45d99c56f02e74dbed (diff)
downloadgit-review-a2219154473c8255110696d7700bb63a7ee5d110.tar.gz
Align to OpenStack Hacking guidelines.
Change-Id: I8eeea3be46d4943c462772de26b10142f426a00c
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 8cdbad9..2b1de91 100755
--- a/setup.py
+++ b/setup.py
@@ -14,10 +14,10 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-from setuptools import setup
-from distutils.command.install import install as du_install
-from setuptools.command.install import install
+from distutils.command import install as du_install
import os.path
+import setuptools
+from setuptools.command import install
import sys
version = None
@@ -28,12 +28,12 @@ exec(open("git-review").read())
__name__ = savename
-class git_review_install(install):
+class git_review_install(install.install):
# Force single-version-externally-managed
# This puts the manpage in the right location (instead of buried
# in an egg)
def run(self):
- return du_install.run(self)
+ return du_install.install.run(self)
git_review_cmdclass = {'install': git_review_install}
@@ -45,7 +45,7 @@ if os.path.exists(os.path.join(sys.prefix, 'man')):
# like to symlink Unixish /usr/local/man to /usr/local/share/man.
manpath = 'man'
-setup(
+setuptools.setup(
name='git-review',
version=version,
cmdclass=git_review_cmdclass,