summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-11-27 22:57:11 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-11-27 23:03:36 +0000
commit59bbb5e4795d2b6e41ce27ae3b18257e75b71a19 (patch)
tree0514fd7dccead69c29ba79fae39b24000d90d24f /meson.build
parent4fa8279ebff4ab462f26370b68599d6f401df8d2 (diff)
downloadgjs-59bbb5e4795d2b6e41ce27ae3b18257e75b71a19.tar.gz
build: disable gir install via list to pacify meson >= 0.60.2
meson.build:580:0: ERROR: "install_dir" must be specified when installing a target installed-tests/js/meson.build:73:0: ERROR: "install_dir" must be specified when installing a target installed-tests/js/meson.build:91:4: ERROR: "install_dir" must be specified when installing a target installed-tests/js/meson.build:104:0: ERROR: "install_dir" must be specified when installing a target installed-tests/js/libgjstesttools/meson.build:13:0: ERROR: "install_dir" must be specified when installing a target
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 437b3fd3..73d0eaca 100644
--- a/meson.build
+++ b/meson.build
@@ -581,7 +581,7 @@ gjs_private_gir = gnome.generate_gir(libgjs,
includes: ['GObject-2.0', 'Gio-2.0'], sources: libgjs_private_sources,
namespace: 'GjsPrivate', nsversion: '1.0', identifier_prefix: 'Gjs',
symbol_prefix: 'gjs_', extra_args: '--warn-error', install: true,
- install_dir_gir: false, install_dir_typelib: pkglibdir / 'girepository-1.0')
+ install_dir_gir: [false], install_dir_typelib: pkglibdir / 'girepository-1.0')
gjs_private_typelib = gjs_private_gir[1]
### Build gjs-console interpreter ##############################################