summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2022-06-08 17:22:39 +0200
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2022-06-13 21:01:30 +0200
commit6662766552262231e2bececc15626e2b9e83241d (patch)
tree8e18d72d1a08de5a44b6e5dc662097f63ba60290 /meson.build
parente0a9fc50bfe9d1dccd0e360545a1768a6101db37 (diff)
downloadgjs-6662766552262231e2bececc15626e2b9e83241d.tar.gz
build: Do not use verbose GJS debug logging in tests by default
Avoid showing all the GJS debug topics information in logs when running meson test, while include them when using the 'verbose' setup that is now used by default in CI tests.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9f8cdacc..1edfb3ef 100644
--- a/meson.build
+++ b/meson.build
@@ -708,6 +708,9 @@ valgrind_args = [
'--error-exitcode=1'
]
+add_test_setup('quiet', env: ['GJS_DEBUG_TOPICS='], is_default: true)
+add_test_setup('verbose')
+
add_test_setup('valgrind', timeout_multiplier: 40, env: valgrind_environment,
exe_wrapper: ['valgrind'] + valgrind_args)