summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Chimento <philip.chimento@gmail.com>2022-11-01 22:21:21 -0700
committerPhilip Chimento <philip.chimento@gmail.com>2022-11-01 22:21:21 -0700
commit8e0dad85268399de770347baac6f43594bb6a51d (patch)
tree64f53c3277e2633222b3d14d82f68b339a072f16 /meson.build
parentda02ead80bc392521fc3ac1ab46c18ba7050212b (diff)
downloadgjs-8e0dad85268399de770347baac6f43594bb6a51d.tar.gz
build: Define path for test libraries on macOS
Running the tests on macOS requires DYLD_FALLBACK_LIBRARY_PATH to be set instead of LD_LIBRARY_PATH.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 94a53ee3..66891b60 100644
--- a/meson.build
+++ b/meson.build
@@ -642,6 +642,8 @@ tests_environment.prepend('GI_TYPELIB_PATH', meson.current_build_dir(),
js_tests_builddir, libgjs_test_tools_builddir)
tests_environment.prepend('LD_LIBRARY_PATH', meson.current_build_dir(),
js_tests_builddir, libgjs_test_tools_builddir)
+tests_environment.prepend('DYLD_FALLBACK_LIBRARY_PATH', meson.current_build_dir(),
+ js_tests_builddir, libgjs_test_tools_builddir)
tests_environment.set('G_FILENAME_ENCODING', 'latin1')
# Workaround for https://github.com/google/sanitizers/issues/1322
tests_environment.set('ASAN_OPTIONS', 'intercept_tls_get_addr=0')