summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorJuan Pablo Ugarte <juanpablougarte@gmail.com>2020-10-06 20:34:11 -0300
committerJuan Pablo Ugarte <juanpablougarte@gmail.com>2020-10-09 17:11:16 -0300
commit20142e2ad10727e1b9ff5693f15f587ff70a0e39 (patch)
treec812cc875283b61ea203c3da629d7d2853bb1392 /src/meson.build
parent9f4097cd74f95ec18428b56d99d814151de9e4fa (diff)
downloadglade-20142e2ad10727e1b9ff5693f15f587ff70a0e39.tar.gz
Fix windows build on msys
Use -Wl,--export-all-symbols and -Wl,--no-undefined to export symbols on mingw GladeApp: use PACKAGE_NAME instead of PACKAGE Remove copyright symbol from resource files to avoid weird UTF error building with mingw on msys
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build18
1 files changed, 15 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index 0b30027c..25038d47 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,4 +1,16 @@
-vcs_tag(input: 'version.h.in', output: 'version.h')
+fs = import('fs')
+
+if fs.exists('../.git')
+ vcs_tag(input: 'version.h.in', output: 'version.h')
+else
+ config = configuration_data()
+ config.set ('VCS_TAG', glade_version)
+ configure_file(
+ input: 'version.h.in',
+ output: 'version.h',
+ configuration: config
+ )
+endif
sources = files(
'glade-http.c',
@@ -39,13 +51,13 @@ ldflags = []
if glade_system == 'windows'
rc = configure_file(
input: 'glade.rc.in',
- output: '@BASELINE@',
+ output: 'glade.rc',
configuration: rc_conf,
)
sources += windows.compile_resources(rc)
- test_ldflags = ['-export-dynamic']
+ test_ldflags = ['-Wl,--export-all-symbols']
if not glade_unstable
test_ldflags += ['-mwindows']
endif