summaryrefslogtreecommitdiff
path: root/gladeui/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gladeui/meson.build')
-rw-r--r--gladeui/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/gladeui/meson.build b/gladeui/meson.build
index 484bf389..8ccf1b4f 100644
--- a/gladeui/meson.build
+++ b/gladeui/meson.build
@@ -184,8 +184,8 @@ endif
if glade_system == 'windows'
rc = configure_file(
- input: 'glade.rc.in',
- output: '@BASELINE@',
+ input: 'gladeui.rc.in',
+ output: 'gladeui.rc',
configuration: rc_conf,
)
@@ -193,8 +193,8 @@ if glade_system == 'windows'
ldflags += cc.get_supported_link_arguments([
# gmodule-export-2.0 on windows does not include -export-dynamic flag
- '-export-dynamic',
- '-no-undefined',
+ '-Wl,--export-all-symbols',
+ '-Wl,--no-undefined',
])
endif
@@ -264,7 +264,7 @@ ldflags = []
if glade_system == 'windows'
rc = configure_file(
input: 'glade-previewer.rc.in',
- output: '@BASELINE@',
+ output: 'glade-previewer.rc',
configuration: rc_conf,
)