summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 44284fc10..1d3754abb 100644
--- a/meson.build
+++ b/meson.build
@@ -828,6 +828,10 @@ if cc.has_header_symbol('dlfcn.h', 'RTLD_NEXT', args: '-D_GNU_SOURCE')
glib_conf.set('HAVE_RTLD_NEXT', 1)
endif
+if cc.has_type('loff_t', prefix: '#include <sys/types.h>')
+ glib_conf.set('HAVE_LOFF_T', 1)
+endif
+
# Check whether to use statfs or statvfs
# Some systems have both statfs and statvfs, pick the most "native" for these
if have_func_statfs and have_func_statvfs