summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Weimer <fweimer@redhat.com>2019-12-03 18:48:18 +0100
committerFlorian Weimer <fweimer@redhat.com>2019-12-03 18:48:18 +0100
commit9fb8139079ef0bb1aa33a4ae418cbb113b9b9da7 (patch)
tree0a48018fcd1d381c1a5f8bcfc2e0101fbd67c31e /configure.ac
parent39c977b23e3e547e70d199a679b37bdf9c3223f6 (diff)
downloadglibc-9fb8139079ef0bb1aa33a4ae418cbb113b9b9da7.tar.gz
x86: Assume --enable-cet if GCC defaults to CET [BZ #25225]
This links in CET support if GCC defaults to CET. Otherwise, __CET__ is defined, yet CET functionality is not compiled and linked into the dynamic loader, resulting in a linker failure due to undefined references to _dl_cet_check and _dl_open_check.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e69c88c543..49b900c1ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -473,11 +473,18 @@ AC_ARG_ENABLE([mathvec],
[build_mathvec=$enableval],
[build_mathvec=notset])
+AC_TRY_COMPILE([], [
+#ifndef __CET__
+# error no CET compiler support
+#endif],
+ [libc_cv_compiler_default_cet=yes],
+ [libc_cv_compiler_default_cet=no])
+
AC_ARG_ENABLE([cet],
AC_HELP_STRING([--enable-cet],
[enable Intel Control-flow Enforcement Technology (CET), x86 only]),
[enable_cet=$enableval],
- [enable_cet=no])
+ [enable_cet=$libc_cv_compiler_default_cet])
# We keep the original values in `$config_*' and never modify them, so we
# can write them unchanged into config.make. Everything else uses