summaryrefslogtreecommitdiff
path: root/MSVC_NMake/giomm/meson.build
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2023-01-04 14:39:23 +0100
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2023-01-04 14:39:23 +0100
commitf740338520a691bb962a2e8d21b28a7f0a086ce1 (patch)
tree1f4d233228093855e6a8e7fc3b19d09066765bad /MSVC_NMake/giomm/meson.build
parentf674418a4564294b5bb77e3c9a72b31ab28122b4 (diff)
downloadglibmm-f740338520a691bb962a2e8d21b28a7f0a086ce1.tar.gz
Meson build: Don't copy files with configure_file()
It's deprecated from Meson 0.64. The replacement, fs.copyfile(), is not useful here. It only copies from the source directory to the build directory.
Diffstat (limited to 'MSVC_NMake/giomm/meson.build')
-rw-r--r--MSVC_NMake/giomm/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/MSVC_NMake/giomm/meson.build b/MSVC_NMake/giomm/meson.build
index 658147df..3bc83150 100644
--- a/MSVC_NMake/giomm/meson.build
+++ b/MSVC_NMake/giomm/meson.build
@@ -1,6 +1,6 @@
# MSVC_NMake/giomm
-# Input: pkg_conf_data, giommconfig_h
+# Input: pkg_conf_data, giommconfig_h_meson
# Output: giomm_rc
giomm_rc = configure_file(
@@ -9,9 +9,9 @@ giomm_rc = configure_file(
configuration: pkg_conf_data,
)
-# Copy the generated configuration header into the MSVC project directory.
+# Make a copy of the generated configuration header in the MSVC project directory.
configure_file(
- input: giommconfig_h,
+ input: giommconfig_h_meson,
output: 'giommconfig.h',
- copy: true,
+ configuration: pkg_conf_data,
)