summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Elstner <daniel.kitta@gmail.com>2009-09-01 22:45:43 +0200
committerDaniel Elstner <daniel.kitta@gmail.com>2009-09-01 22:45:43 +0200
commit5b9bd92a67a3faa7b5ba00bd256b02a96275f433 (patch)
tree14e63c09f2f67374f33d013672e86a90497a1e21 /Makefile.am
parentadf781ceae0a6e9161dd5d0a32356d77960e8d5c (diff)
downloadglibmm-5b9bd92a67a3faa7b5ba00bd256b02a96275f433.tar.gz
Always build tools/ subdirectory (bgo #593518)
* Makefile.am (SUBDIRS): Unconditionally recurse into the tools/ subdirectory, rather than only in maintainer-mode. Otherwise, the code generator support files located there would not be installed when building a tarball of glibmm.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b45cf50f..d99bea95 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@ ACLOCAL_AMFLAGS = -I build ${ACLOCAL_FLAGS}
DISTCHECK_CONFIGURE_FLAGS = --enable-warnings=fatal
if MAINTAINER_MODE
-src_subdirs = tools glib/src gio/src
+src_subdirs = glib/src gio/src
else
src_subdirs =
endif
@@ -28,7 +28,7 @@ doc_subdirs = docs
else
doc_subdirs =
endif
-SUBDIRS = $(src_subdirs) glib/glibmm gio/giomm tests examples $(doc_subdirs)
+SUBDIRS = tools $(src_subdirs) glib/glibmm gio/giomm tests examples $(doc_subdirs)
glibmm_includedir = $(includedir)/$(GLIBMM_MODULE_NAME)
glibmm_include_HEADERS = glib/glibmm.h