summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2018-08-17 17:33:14 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2018-09-07 15:17:11 +0800
commit661e3f6b93fa30e1129cf1b9fa489812318d9f28 (patch)
tree5bcc6b80a941a106635f4c0206903381520f5e4f /Makefile.am
parentce26359162e78dd4c510583b68785786c69572bf (diff)
downloadglibmm-661e3f6b93fa30e1129cf1b9fa489812318d9f28.tar.gz
build: Add NMake Makefiles
This adds a set of NMake Makefiles which can be used to build glibmm with Visual Studio 2017 and later. This will supersede the Visual Studio 2017 project files, as this approach will reduce the likelihood of the Visual Studio build files becoming out-of-date as this also reads from the various filelist.am's under glib/ and gio/. The existing gendef, and generated [glib|gio]mmconfig.h and generated [glib|gio]mm.rc will continue to be used. The NMake Makefiles will now be distributed instead of the Visual Studio project files from this point on. The Visual Studio project files will be removed in the next commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f497ffef..1b366b4c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,7 @@ nodist_pkgconfig_DATA = glib/$(GLIBMM_MODULE_NAME).pc gio/$(GIOMM_MODULE_NAME).p
include $(srcdir)/MSVC_NMake/filelist.am
text_files = COPYING.tools README.SUN README.win32
-msvc_files = $(addprefix MSVC_NMake/,$(msvc_net2017_data))
+msvc_files = $(addprefix MSVC_NMake/,$(msvc_nmake_data))
dist_noinst_DATA = $(text_files) $(msvc_files)
dist_noinst_SCRIPTS = autogen.sh