summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanc999@yahoo.com.tw>2021-05-14 18:47:09 +0000
committerChun-wei Fan <fanc999@yahoo.com.tw>2021-05-14 18:47:09 +0000
commit19f08ffaf2c7245c240013be36b2f44f87582d6f (patch)
treeeefd50064613c590a9950a5c845f832f0c7dceef /meson.build
parent9685f6fc8962efc1534c3a5ba5b4e477631ad3f1 (diff)
parenteabcc013a3d6f9863c01a51142514423b4aa8c04 (diff)
downloadglibmm-19f08ffaf2c7245c240013be36b2f44f87582d6f.tar.gz
Merge branch 'std-string-msvc-fixes' into 'master'
Export classes selectively (fix issue #90) Closes #90 See merge request GNOME/glibmm!51
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2f7144a5..df3bf517 100644
--- a/meson.build
+++ b/meson.build
@@ -209,7 +209,7 @@ msvc14x_toolset_ver = ''
# that should not be overlooked stand out.
if is_msvc
disabled_warnings = cpp_compiler.get_supported_arguments([
- '/FImsvc_recommended_pragmas.h', '/wd4251', '/wd4275', '/wd4267', '/wd4530', '/wd4589', '/utf-8'
+ '/FImsvc_recommended_pragmas.h', '/wd4267', '/EHsc', '/utf-8'
])
add_project_arguments(disabled_warnings, language: 'cpp')