summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2020-03-02 15:33:03 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2020-03-02 15:33:03 +0800
commit7fd70401a16957ff9f5c9aac401a959c2f6b29e6 (patch)
tree753c79e7045abac20acc62f762e6ffc7a7fbf719 /meson.build
parent2b6cc806a54b853980fae8b36f7af0d568a4950f (diff)
downloadglibmm-7fd70401a16957ff9f5c9aac401a959c2f6b29e6.tar.gz
meson.build: Disable warning C4589 on Visual Studio
This warning can be ignored as well.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e0f78dd3..80d7dd5e 100644
--- a/meson.build
+++ b/meson.build
@@ -194,7 +194,7 @@ add_project_arguments(warning_flags, language: 'cpp')
# that should not be overlooked stand out.
if is_msvc
disabled_warnings = cpp_compiler.get_supported_arguments([
- '/FImsvc_recommended_pragmas.h', '/wd4267', '/wd4530'
+ '/FImsvc_recommended_pragmas.h', '/wd4267', '/wd4530', '/wd4589'
])
add_project_arguments(disabled_warnings, language: 'cpp')
endif