summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2021-06-24 13:18:35 -0700
committerMatt Turner <mattst88@gmail.com>2021-06-24 13:27:56 -0700
commita172e0aec8f537f365078dab5486cae9c9a6880e (patch)
tree63a7709e0b5695917530f6eddc2391d3b558907d /Makefile.am
parentfb5ded2fcfb5c3287b3be1810331577098bd291c (diff)
downloadglu-a172e0aec8f537f365078dab5486cae9c9a6880e.tar.gz
Remove glu_mangle.h
Long ago when GLU lived in the Mesa repository, there was "name mangling" support that allowed you to build Mesa and GLU with all exported symbols' names "mangled". That is, the symbol names would typically be prefixed with an 'm' so that they would not collide with the system's OpenGL implementation. When GLU was split out into its own repository in 2012 we didn't bring over the name mangling support. No one has noticed this lack of functionality since, to my knowledge. Remove the name mangling header (which was unexpectedly licensed under the GPL).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index cb1bef9..9a26249 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,8 +35,7 @@ AM_CXXFLAGS = $(GL_CFLAGS) $(LIBGLVND_CFLAGS) $(OSMESA_CFLAGS) $(WARNCXXFLAGS) $
GL_includedir = $(includedir)/GL
GL_include_HEADERS = \
- $(top_srcdir)/include/GL/glu.h \
- $(top_srcdir)/include/GL/glu_mangle.h
+ $(top_srcdir)/include/GL/glu.h
GLU_LIBRARY_VERSION=1:3:1
lib_LTLIBRARIES = libGLU.la
@@ -137,7 +136,6 @@ EXTRA_DIST = \
meson.build \
meson_options.txt \
include/GL/glu.h \
- include/GL/glu_mangle.h \
src/meson.build \
src/libtess/render.h \
src/libtess/tessmono.h \