summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2021-06-24 13:18:35 -0700
committerMatt Turner <mattst88@gmail.com>2021-06-24 13:27:56 -0700
commita172e0aec8f537f365078dab5486cae9c9a6880e (patch)
tree63a7709e0b5695917530f6eddc2391d3b558907d /meson.build
parentfb5ded2fcfb5c3287b3be1810331577098bd291c (diff)
downloadglu-a172e0aec8f537f365078dab5486cae9c9a6880e.tar.gz
Remove glu_mangle.h
Long ago when GLU lived in the Mesa repository, there was "name mangling" support that allowed you to build Mesa and GLU with all exported symbols' names "mangled". That is, the symbol names would typically be prefixed with an 'm' so that they would not collide with the system's OpenGL implementation. When GLU was split out into its own repository in 2012 we didn't bring over the name mangling support. No one has noticed this lack of functionality since, to my knowledge. Remove the name mangling header (which was unexpectedly licensed under the GPL).
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c0de7b6..c84dfc0 100644
--- a/meson.build
+++ b/meson.build
@@ -6,7 +6,7 @@ project(
['c', 'cpp'],
version : '9.0.1',
meson_version : '>= 0.52.0',
- license : 'SGI-B-1.1 AND SGI-B-2.0 AND MIT AND GPL-2.0-or-later',
+ license : 'SGI-B-1.1 AND SGI-B-2.0 AND MIT',
default_options : ['default_library=both', 'b_ndebug=if-release']
)
@@ -25,7 +25,6 @@ inc_include = include_directories('include')
subdir('src')
install_headers(
- 'include/GL/glu_mangle.h',
'include/GL/glu.h',
subdir : 'GL',
)