summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build38
1 files changed, 38 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..c0de7b6
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,38 @@
+# SPDX-License-Identifier: MIT
+# Copyright © 2021 Intel Corporation
+
+project(
+ 'glu',
+ ['c', 'cpp'],
+ version : '9.0.1',
+ meson_version : '>= 0.52.0',
+ license : 'SGI-B-1.1 AND SGI-B-2.0 AND MIT AND GPL-2.0-or-later',
+ default_options : ['default_library=both', 'b_ndebug=if-release']
+)
+
+if get_option('debug')
+ add_project_arguments('-DDEBUG', language : ['c', 'cpp'])
+endif
+
+gl_provider = get_option('gl_provider')
+if gl_provider == 'glvnd'
+ gl_provider = 'opengl'
+endif
+dep_gl = dependency(gl_provider)
+
+inc_include = include_directories('include')
+
+subdir('src')
+
+install_headers(
+ 'include/GL/glu_mangle.h',
+ 'include/GL/glu.h',
+ subdir : 'GL',
+)
+
+pkgconf = import('pkgconfig')
+pkgconf.generate(
+ libglu,
+ name : 'glu',
+ description : 'Mesa OpenGL Utility Library',
+)