summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2003-10-11 22:51:56 +0200
committerKevin Ryde <user42@zip.com.au>2003-10-11 22:51:56 +0200
commiteb7611770f521cf86bd377ab7a369f2ae7c5934d (patch)
treea269765c2a76444da09cb8a249c7efa90de74bd7 /Makefile.am
parent3d9e7ec041e32191917969c23ff10b65d7b63a03 (diff)
downloadgmp-eb7611770f521cf86bd377ab7a369f2ae7c5934d.tar.gz
* Makefile.am (install-data-hook): Print a warning recommending "make
check" to watch out for compiler bugs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1028b70d3..f6db4dcd2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -294,6 +294,23 @@ info_TEXINFOS = gmp.texi
gmp_TEXINFOS = fdl.texi
+install-data-hook:
+ @echo ''
+ @echo '+-------------------------------------------------------------+'
+ @echo '| CAUTION: |'
+ @echo '| |'
+ @echo '| If you have not already run "make check", then we strongly |'
+ @echo '| recommend you do so. |'
+ @echo '| |'
+ @echo '| GMP has been carefully tested by its authors, but compilers |'
+ @echo '| are all too often released with serious bugs. GMP tends to |'
+ @echo '| explore interesting corners in compilers and has hit bugs |'
+ @echo '| on quite a few occasions. |'
+ @echo '| |'
+ @echo '+-------------------------------------------------------------+'
+ @echo ''
+
+
# The ansi2knr setups for the build programs are the same as the normal
# automake ansi2knr rules, but using $(CC_FOR_BUILD) instead of $(CC).
#