summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels M?ller <nisse@lysator.liu.se>2018-04-22 21:22:29 +0200
committerNiels M?ller <nisse@lysator.liu.se>2018-04-22 21:22:29 +0200
commit03b2c76e043ce9fa262cb4f98d1193bc743d4797 (patch)
treeb035b8f48c0497518745788785c0328f90d76752 /configure.ac
parent84effdd707b57bdfb62110b85c4ae4eb69cdac52 (diff)
downloadgmp-03b2c76e043ce9fa262cb4f98d1193bc743d4797.tar.gz
Configure tweaks for windows on aarch64.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 18384990f..e74edf641 100644
--- a/configure.ac
+++ b/configure.ac
@@ -602,8 +602,8 @@ case $host in
CALLING_CONVENTIONS_OBJS='arm32call.lo arm32check.lo'
CALLING_CONVENTIONS_OBJS_64=""
cclist_64="gcc cc"
- any_32_testlist="sizeof-long-4"
- any_64_testlist="sizeof-long-8"
+ any_32_testlist="sizeof-void*-4"
+ any_64_testlist="sizeof-void*-8"
# This is needed for clang, which is not content with flags like -mfpu=neon
# alone.
@@ -612,6 +612,8 @@ case $host in
gcc_cflags_fpmode="-mfloat-abi=softfp" ;;
*-*-*eabihf)
gcc_cflags_fpmode="-mfloat-abi=hard" ;;
+ *-*-mingw*)
+ limb_64=longlong ;;
esac
# FIXME: We make mandatory compiler options optional here. We should