summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTorbjorn Granlund <tg@gmplib.org>2019-08-19 10:28:48 +0200
committerTorbjorn Granlund <tg@gmplib.org>2019-08-19 10:28:48 +0200
commit589f811ac0c866b8c8f35b2313fe26109cf7f816 (patch)
tree3c81f89f03c9d352c0ba11b7e6373bc54de8a500 /configure.ac
parent8771dfed6865ff9163d68089c1f8ea0b4520d27f (diff)
downloadgmp-589f811ac0c866b8c8f35b2313fe26109cf7f816.tar.gz
Check for ELFv1 ABI on PowerPC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fc102b57e..21f32e7c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3683,6 +3683,13 @@ if test "$gmp_asm_syntax_testing" != no; then
GMP_ASM_POWERPC_R_REGISTERS
GMP_INCLUDE_MPN(powerpc32/powerpc-defs.m4)
+ # Check for Linux ELFv1 ABI
+ AC_EGREP_CPP(yes,
+[#if _CALL_ELF == 1
+yes
+#endif],
+ [GMP_DEFINE_RAW(["define(<ELFv1_ABI>)"])])
+
# Check for Linux ELFv2 ABI
AC_EGREP_CPP(yes,
[#if _CALL_ELF == 2