summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels M?ller <nisse@lysator.liu.se>2019-08-16 08:00:46 +0200
committerNiels M?ller <nisse@lysator.liu.se>2019-08-16 08:00:46 +0200
commit694d0c60b43d40bd18bcf5dda6ba1181cedd1324 (patch)
tree889630dee3f2aac7e0cc85cdb7d8f893cd216094 /configure.ac
parent58b80c88cdbd0af5ebcec9f731f93b74db8d9d1b (diff)
downloadgmp-694d0c60b43d40bd18bcf5dda6ba1181cedd1324.tar.gz
New function mpn_gcd_22.
* mpn/generic/gcd.c (gcd_2): Moved to gcd_22.c below. (mpn_gcd): Adapt for calling gcd_22. * mpn/generic/gcd_22.c (mpn_gcd_22): New file and function. * gmp-impl.h (mp_double_limb_t): New (typedef) struct. * configure.ac (gmp_mpn_functions): Added gcd_22. * tests/mpn/t-gcd_22.c: New test. * tests/mpn/Makefile.am (check_PROGRAMS): Add t-gcd_22. * tests/refmpz.c (refmpz_gcd): New function (plain binary gcd).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 18f1ee5d6..fc102b57e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2970,7 +2970,7 @@ gmp_mpn_functions="$extra_functions \
rootrem sqrtrem sizeinbase get_str set_str compute_powtab \
scan0 scan1 popcount hamdist cmp zero_p \
perfsqr perfpow strongfibo \
- gcd_11 gcd_1 gcd gcdext_1 gcdext gcd_subdiv_step \
+ gcd_11 gcd_22 gcd_1 gcd gcdext_1 gcdext gcd_subdiv_step \
gcdext_lehmer \
div_q tdiv_qr jacbase jacobi_2 jacobi get_d \
matrix22_mul matrix22_mul1_inverse_vector \