summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTorbjorn Granlund <tg@gmplib.org>2022-03-30 23:13:11 +0200
committerTorbjorn Granlund <tg@gmplib.org>2022-03-30 23:13:11 +0200
commitefe1e60af3cd3fd34c8b3303c5b6e33333baebd4 (patch)
treece06bb4755f888c57e92b54a0c7fd4e5a6b6cf3a /configure.ac
parent58818388634ac42301e50c9b2dbd65340fb3ab70 (diff)
downloadgmp-efe1e60af3cd3fd34c8b3303c5b6e33333baebd4.tar.gz
Handle Intel tremont separately.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 05b5cb4b3..d86c494b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -333,6 +333,7 @@ AH_VERBATIM([HAVE_HOST_CPU_1],
#undef HAVE_HOST_CPU_skylake
#undef HAVE_HOST_CPU_silvermont
#undef HAVE_HOST_CPU_goldmont
+#undef HAVE_HOST_CPU_tremont
#undef HAVE_HOST_CPU_k8
#undef HAVE_HOST_CPU_k10
#undef HAVE_HOST_CPU_bulldozer
@@ -1997,6 +1998,12 @@ case $host in
path="x86/goldmont x86/atom/sse2 x86/atom/mmx x86/atom x86/mmx x86"
path_64="x86_64/goldmont x86_64/silvermont x86_64/atom x86_64"
;;
+ tremont) # out-of-order pipeline atom
+ gcc_cflags_cpu="-mtune=slm -mtune=atom -mtune=pentium3"
+ gcc_cflags_arch="-march=slm -march=atom -march=pentium3"
+ path="x86/goldmont x86/atom/sse2 x86/atom/mmx x86/atom x86/mmx x86"
+ path_64="x86_64/tremont x86_64/goldmont x86_64/silvermont x86_64/atom x86_64"
+ ;;
nano)
gcc_cflags_cpu="-mtune=nano"
gcc_cflags_arch="-march=nano"