summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTorbjorn Granlund <tege@gmplib.org>2008-12-07 17:15:47 +0100
committerTorbjorn Granlund <tege@gmplib.org>2008-12-07 17:15:47 +0100
commit3bf49e17d01159550b86ed672e31363266c32dbf (patch)
treed5c49ca36cc5963a3c50705f0d606da7a8fc0fcb /configure.in
parent655ede5ecd201c53baf3aeb7db47e8b561f54d70 (diff)
downloadgmp-3bf49e17d01159550b86ed672e31363266c32dbf.tar.gz
(gmp_mpn_functions): Add mul_toom33. Reformat.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in102
1 files changed, 51 insertions, 51 deletions
diff --git a/configure.in b/configure.in
index fe7f1b215..9120f45f5 100644
--- a/configure.in
+++ b/configure.in
@@ -491,19 +491,19 @@ case $host in
# not sure if -fast works on old versions, so make it optional
cc_cflags_opt="-fast -O2"
- # DEC C V5.9-005 knows ev4, ev5, ev56, pca56, ev6.
- # Compaq C V6.3-029 adds ev67.
- #
- case $host_cpu in
- alpha) cc_cflags_cpu="-arch~ev4~-tune~ev4" ;;
- alphaev5) cc_cflags_cpu="-arch~ev5~-tune~ev5" ;;
- alphaev56) cc_cflags_cpu="-arch~ev56~-tune~ev56" ;;
- alphapca56 | alphapca57)
+ # DEC C V5.9-005 knows ev4, ev5, ev56, pca56, ev6.
+ # Compaq C V6.3-029 adds ev67.
+ #
+ case $host_cpu in
+ alpha) cc_cflags_cpu="-arch~ev4~-tune~ev4" ;;
+ alphaev5) cc_cflags_cpu="-arch~ev5~-tune~ev5" ;;
+ alphaev56) cc_cflags_cpu="-arch~ev56~-tune~ev56" ;;
+ alphapca56 | alphapca57)
cc_cflags_cpu="-arch~pca56~-tune~pca56" ;;
- alphaev6) cc_cflags_cpu="-arch~ev6~-tune~ev6" ;;
- alphaev67 | alphaev68 | alphaev7*)
+ alphaev6) cc_cflags_cpu="-arch~ev6~-tune~ev6" ;;
+ alphaev67 | alphaev68 | alphaev7*)
cc_cflags_cpu="-arch~ev67~-tune~ev67 -arch~ev6~-tune~ev6" ;;
- esac
+ esac
;;
*)
GMP_INCLUDE_MPN(alpha/default.m4)
@@ -919,7 +919,7 @@ case $host in
# -qarch=ppc is needed, so ensure everything falls back to that.
# FIXME: Perhaps newer versions know more flavours.
#
- case $host_cpu in
+ case $host_cpu in
powerpc403) xlc_cflags_arch="-qarch=403 -qarch=ppc" ;;
powerpc601) xlc_cflags_arch="-qarch=601 -qarch=ppc" ;;
powerpc602) xlc_cflags_arch="-qarch=602 -qarch=ppc" ;;
@@ -1148,40 +1148,40 @@ case $host in
# SunPRO cc and acc, and SunOS bundled cc
case $host in
*-*-solaris* | *-*-sunos*)
- # Note no -g, it disables all optimizations.
- cc_cflags=
- cc_cflags_optlist="opt arch cpu"
+ # Note no -g, it disables all optimizations.
+ cc_cflags=
+ cc_cflags_optlist="opt arch cpu"
# SunOS cc doesn't know -xO4, fallback to -O2.
- cc_cflags_opt="-xO4 -O2"
+ cc_cflags_opt="-xO4 -O2"
# SunOS cc doesn't know -xarch, apparently always generating v7
# code, so make this optional
- case $host_cpu in
- sparcv8 | microsparc | supersparc | turbosparc)
+ case $host_cpu in
+ sparcv8 | microsparc | supersparc | turbosparc)
cc_cflags_arch="-xarch=v8" ;;
- sparc64 | sparcv9* | ultrasparc*) cc_cflags_arch="-xarch=v8plus" ;;
- *) cc_cflags_arch="-xarch=v7" ;;
- esac
+ sparc64 | sparcv9* | ultrasparc*) cc_cflags_arch="-xarch=v8plus" ;;
+ *) cc_cflags_arch="-xarch=v7" ;;
+ esac
# SunOS cc doesn't know -xchip and doesn't seem to have an equivalent.
- # SunPRO cc 5 recognises -xchip=generic, old, super, super2, micro,
- # micro2, hyper, hyper2, powerup, ultra, ultra2, ultra2i.
- # SunPRO cc 6 adds -xchip=ultra2e, ultra3cu.
+ # SunPRO cc 5 recognises -xchip=generic, old, super, super2, micro,
+ # micro2, hyper, hyper2, powerup, ultra, ultra2, ultra2i.
+ # SunPRO cc 6 adds -xchip=ultra2e, ultra3cu.
#
- # FIXME: Which of ultra, ultra2 or ultra2i is the best fallback for
- # ultrasparc3?
- #
- case $host_cpu in
- supersparc) cc_cflags_cpu="-xchip=super" ;;
- microsparc) cc_cflags_cpu="-xchip=micro" ;;
- turbosparc) cc_cflags_cpu="-xchip=micro2" ;;
- ultrasparc) cc_cflags_cpu="-xchip=ultra" ;;
- ultrasparc2) cc_cflags_cpu="-xchip=ultra2" ;;
- ultrasparc2i) cc_cflags_cpu="-xchip=ultra2i" ;;
- ultrasparc3) cc_cflags_cpu="-xchip=ultra3 -xchip=ultra" ;;
- *) cc_cflags_cpu="-xchip=generic" ;;
- esac
+ # FIXME: Which of ultra, ultra2 or ultra2i is the best fallback for
+ # ultrasparc3?
+ #
+ case $host_cpu in
+ supersparc) cc_cflags_cpu="-xchip=super" ;;
+ microsparc) cc_cflags_cpu="-xchip=micro" ;;
+ turbosparc) cc_cflags_cpu="-xchip=micro2" ;;
+ ultrasparc) cc_cflags_cpu="-xchip=ultra" ;;
+ ultrasparc2) cc_cflags_cpu="-xchip=ultra2" ;;
+ ultrasparc2i) cc_cflags_cpu="-xchip=ultra2i" ;;
+ ultrasparc3) cc_cflags_cpu="-xchip=ultra3 -xchip=ultra" ;;
+ *) cc_cflags_cpu="-xchip=generic" ;;
+ esac
esac
case $host_cpu in
@@ -2424,12 +2424,12 @@ gmp_mpn_functions="$extra_functions \
fib2_ui mod_1 mod_34lsub1 mode1o pre_divrem_1 pre_mod_1 dump \
mul mul_fft mul_n mul_basecase sqr_basecase random random2 pow_1 \
rootrem sqrtrem get_str set_str scan0 scan1 popcount hamdist cmp perfsqr \
- bdivmod gcd_1 gcd gcdext_1 gcdext gcd_lehmer gcd_subdiv_step \
- gcdext_lehmer gcdext_subdiv_step \
- tdiv_qr dc_divrem_n sb_divrem_mn jacbase get_d \
- matrix22_mul \
- hgcd2 hgcd mullow_n mullow_basecase \
- mul_toom22 mul_toom32 mul_toom42 mul_toom62 mul_toom53 mul_toom44 \
+ bdivmod gcd_1 gcd gcdext_1 gcdext gcd_lehmer gcd_subdiv_step \
+ gcdext_lehmer gcdext_subdiv_step \
+ tdiv_qr dc_divrem_n sb_divrem_mn jacbase get_d \
+ matrix22_mul hgcd2 hgcd mullow_n mullow_basecase \
+ mul_toom22 mul_toom33 mul_toom44 \
+ mul_toom32 mul_toom42 mul_toom62 mul_toom53 \
toom_interpolate_5pts toom_interpolate_7pts invert binvert \
sb_div_qr sb_divappr_q sb_div_q dc_div_qr dc_divappr_q dc_div_q \
mu_div_qr mu_divappr_q mu_div_q \
@@ -2483,12 +2483,12 @@ dnl divexact_1.
dnl
define(GMP_FILE_TO_FUNCTION,
[case $$2 in
- dive_1) $1=divexact_1 ;;
- diveby3) $1=divexact_by3c ;;
+ dive_1) $1=divexact_1 ;;
+ diveby3) $1=divexact_by3c ;;
pre_divrem_1) $1=preinv_divrem_1 ;;
- mode1o) $1=modexact_1c_odd ;;
- pre_mod_1) $1=preinv_mod_1 ;;
- *) $1=$$2 ;;
+ mode1o) $1=modexact_1c_odd ;;
+ pre_mod_1) $1=preinv_mod_1 ;;
+ *) $1=$$2 ;;
esac
])
@@ -3017,9 +3017,9 @@ if test "$gmp_asm_syntax_testing" != no; then
GMP_ASM_COFF_TYPE
GMP_ASM_X86_GOT_UNDERSCORE
GMP_ASM_X86_SHLDL_CL
- case $enable_profiling in
- prof | gprof) GMP_ASM_X86_MCOUNT ;;
- esac
+ case $enable_profiling in
+ prof | gprof) GMP_ASM_X86_MCOUNT ;;
+ esac
case $host in
*-*-darwin*)
GMP_INCLUDE_MPN(x86/darwin.m4) ;;