summaryrefslogtreecommitdiff
path: root/mpf/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2000-04-09 22:15:44 +0200
committerKevin Ryde <user42@zip.com.au>2000-04-09 22:15:44 +0200
commita0d40ed108ccf63c92705cebcb32a2428dc3386d (patch)
tree16063599944bbf0359eb1d3fc64a85c6dec28ec4 /mpf/Makefile.am
parent98a715135267dfd036a8811204d1c9dbc407d5df (diff)
downloadgmp-a0d40ed108ccf63c92705cebcb32a2428dc3386d.tar.gz
Add SUBDIRS=tests, use $(top_builddir), add DISTCLEANFILES.
Diffstat (limited to 'mpf/Makefile.am')
-rw-r--r--mpf/Makefile.am30
1 files changed, 26 insertions, 4 deletions
diff --git a/mpf/Makefile.am b/mpf/Makefile.am
index cb3330fa6..c52819eb7 100644
--- a/mpf/Makefile.am
+++ b/mpf/Makefile.am
@@ -1,10 +1,30 @@
## Process this file with automake to generate Makefile.in
+# Copyright (C) 1996, 1998, 1999, 2000 Free Software Foundation, Inc.
+#
+# This file is part of the GNU MP Library.
+#
+# The GNU MP Library is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or (at your
+# option) any later version.
+#
+# The GNU MP Library is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Library General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Library General Public License
+# along with the GNU MP Library; see the file COPYING.LIB. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
+# MA 02111-1307, USA.
+
+
AUTOMAKE_OPTIONS = gnu
-# $top_srcdir is needed for `#include "gmp-impl.h"'.
-# .. is needed for config.h and gmp-mparam.h.
-INCLUDES = -I$(top_srcdir) -I..
+SUBDIRS = tests
+
+INCLUDES = -I$(top_srcdir) -I$(top_builddir)
noinst_LTLIBRARIES = libmpf.la
libmpf_la_SOURCES = \
@@ -19,7 +39,9 @@ nodist_libmpf_la_SOURCES = floor.c ceil.c trunc.c
H = $(top_srcdir)/gmp.h $(top_srcdir)/gmp-impl.h ../gmp-mparam.h
-EXTRA_DIST = integer.c tests
+EXTRA_DIST = integer.c
+
+DISTCLEANFILES = $(nodist_libmpf_la_SOURCES)
floor.c: $(srcdir)/integer.c
cp $(srcdir)/integer.c floor.c