summaryrefslogtreecommitdiff
path: root/mpf/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2000-04-23 02:10:50 +0200
committerKevin Ryde <user42@zip.com.au>2000-04-23 02:10:50 +0200
commitd096585e60174c32814032717a874a1986a6faae (patch)
tree1cc5812342eeb9f9927ede4a14522c93a552dddb /mpf/Makefile.am
parentba26822abd38e0be3b6863b99a3f085bc6d7c1ce (diff)
downloadgmp-d096585e60174c32814032717a874a1986a6faae.tar.gz
* mpf/Makefile.am: Add -DOPERATION_$* for new integer.c.
Remove explicit rules for floor.o etc.
Diffstat (limited to 'mpf/Makefile.am')
-rw-r--r--mpf/Makefile.am22
1 files changed, 3 insertions, 19 deletions
diff --git a/mpf/Makefile.am b/mpf/Makefile.am
index 78eef5f33..e94045b1f 100644
--- a/mpf/Makefile.am
+++ b/mpf/Makefile.am
@@ -24,7 +24,7 @@ AUTOMAKE_OPTIONS = gnu no-dependencies
SUBDIRS = tests
-INCLUDES = -I$(top_srcdir)
+INCLUDES = -I$(top_srcdir) -DOPERATION_$*
noinst_LTLIBRARIES = libmpf.la
libmpf_la_SOURCES = \
@@ -35,31 +35,15 @@ libmpf_la_SOURCES = \
cmp.c cmp_ui.c cmp_si.c mul_2exp.c div_2exp.c abs.c neg.c get_d.c \
set_dfl_prec.c set_prc.c set_prc_raw.c get_prc.c ui_div.c sqrt_ui.c \
pow_ui.c urandomb.c
-nodist_libmpf_la_SOURCES = floor.c ceil.c trunc.c
-H = $(top_srcdir)/gmp.h $(top_srcdir)/gmp-impl.h ../gmp-mparam.h
+nodist_libmpf_la_SOURCES = floor.c ceil.c trunc.c
EXTRA_DIST = integer.c
-
-DISTCLEANFILES = $(nodist_libmpf_la_SOURCES)
+CLEANFILES = $(nodist_libmpf_la_SOURCES)
floor.c: $(srcdir)/integer.c
cp $(srcdir)/integer.c floor.c
-floor.o: floor.c $(H)
- $(COMPILE) -c -DMPF_FLOOR floor.c
-floor.lo: floor.c $(H)
- $(LTCOMPILE) -c -DMPF_FLOOR floor.c
-
ceil.c: $(srcdir)/integer.c
cp $(srcdir)/integer.c ceil.c
-ceil.o: ceil.c $(H)
- $(COMPILE) -c -DMPF_CEIL ceil.c
-ceil.lo: ceil.c $(H)
- $(LTCOMPILE) -c -DMPF_CEIL ceil.c
-
trunc.c: $(srcdir)/integer.c
cp $(srcdir)/integer.c trunc.c
-trunc.o: trunc.c $(H)
- $(COMPILE) -c -DMPF_TRUNC trunc.c
-trunc.lo: trunc.c $(H)
- $(LTCOMPILE) -c -DMPF_TRUNC trunc.c