summaryrefslogtreecommitdiff
path: root/mpz/Makefile.am
diff options
context:
space:
mode:
authorMarco Bodrato <bodrato@mail.dm.unipi.it>2012-01-26 22:19:40 +0100
committerMarco Bodrato <bodrato@mail.dm.unipi.it>2012-01-26 22:19:40 +0100
commitc714a4ab05ae98478ceebd291ce503d3c827a015 (patch)
treeec130909f478b6762a2b94a6e4178a506967833e /mpz/Makefile.am
parentc212d72f36b9980e9b18791de62e07a76f4b40e8 (diff)
downloadgmp-c714a4ab05ae98478ceebd291ce503d3c827a015.tar.gz
mpz_prodlimbs: removed from mpz/fac_ui.c, now in a new file.
Diffstat (limited to 'mpz/Makefile.am')
-rw-r--r--mpz/Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/mpz/Makefile.am b/mpz/Makefile.am
index 74c2c3444..35ec7a1b1 100644
--- a/mpz/Makefile.am
+++ b/mpz/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to generate Makefile.in
-# Copyright 1996, 1998, 1999, 2000, 2001, 2002, 2003 Free Software
+# Copyright 1996, 1998, 1999, 2000, 2001, 2002, 2003, 2012 Free Software
# Foundation, Inc.
#
# This file is part of the GNU MP Library.
@@ -45,16 +45,10 @@ libmpz_la_SOURCES = aors.h aors_ui.h fits_s.h mul_i.h \
lcm.c lcm_ui.c lucnum_ui.c lucnum2_ui.c millerrabin.c \
mod.c mul.c mul_2exp.c mul_si.c mul_ui.c n_pow_ui.c neg.c nextprime.c \
out_raw.c out_str.c perfpow.c perfsqr.c popcount.c pow_ui.c powm.c \
- powm_sec.c powm_ui.c pprime_p.c random.c random2.c \
+ powm_sec.c powm_ui.c pprime_p.c prodlimbs.c random.c random2.c \
realloc.c realloc2.c remove.c root.c rootrem.c rrandomb.c \
scan0.c scan1.c set.c set_d.c set_f.c set_q.c set_si.c set_str.c \
set_ui.c setbit.c size.c sizeinbase.c sqrt.c sqrtrem.c sub.c sub_ui.c \
swap.c tdiv_ui.c tdiv_q.c tdiv_q_2exp.c tdiv_q_ui.c tdiv_qr.c \
tdiv_qr_ui.c tdiv_r.c tdiv_r_2exp.c tdiv_r_ui.c tstbit.c ui_pow_ui.c \
ui_sub.c urandomb.c urandomm.c xor.c
-
-# These are BUILT_SOURCES at the top-level, so normally they're built before
-# recursing into this directory.
-#
-fac_ui.h:
- cd ..; $(MAKE) $(AM_MAKEFLAGS) mpz/fac_ui.h