summaryrefslogtreecommitdiff
path: root/printf/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2001-08-17 00:02:25 +0200
committerKevin Ryde <user42@zip.com.au>2001-08-17 00:02:25 +0200
commitd2535ffc36bea57b020e3ff21e04fb4b1f317fbc (patch)
tree85c613b063fba521bfb504867155eedabe05198b /printf/Makefile.am
parentf37d11ece1a25760c1175e3da022a86d68e6e7e6 (diff)
downloadgmp-d2535ffc36bea57b020e3ff21e04fb4b1f317fbc.tar.gz
* configure.in, acinclude.m4, Makefile.am, printf/Makefile.am,
tests/printf/Makefile.am, gmp-h.in, gmp-impl.h, gmp.texi: Remove C++ support, for the time being.
Diffstat (limited to 'printf/Makefile.am')
-rw-r--r--printf/Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/printf/Makefile.am b/printf/Makefile.am
index 42b3bd93e..22a20ec62 100644
--- a/printf/Makefile.am
+++ b/printf/Makefile.am
@@ -24,19 +24,10 @@ AUTOMAKE_OPTIONS = gnu no-dependencies $(top_builddir)/ansi2knr
INCLUDES = -D__GMP_WITHIN_GMP -I$(top_srcdir)
-# Need C objects in their own convenience library since if a C++ object is
-# there then $(CXX) will be used in the libtool command, and that's not
-# always available.
-
-EXTRA_LTLIBRARIES = libcxxprintf.la
-noinst_LTLIBRARIES = libprintf.la @LIBCXXPRINTF_LA@
+noinst_LTLIBRARIES = libprintf.la
libprintf_la_SOURCES = \
asprintf.c doprnt.c doprntf.c doprnti.c \
fprintf.c obprintf.c obvprintf.c obprntffuns.c \
printf.c printffuns.c snprintf.c snprntffuns.c sprintf.c sprintffuns.c \
- vasprintf.c vfprintf.c vprintf.c vsnprintf.c vsprintf.c \
- $(OPTION_CXX)
-
-libcxxprintf_la_SOURCES = \
- doprntfx.cc doprntix.cc osfuns.cc osmpf.cc osmpq.cc osmpz.cc
+ vasprintf.c vfprintf.c vprintf.c vsnprintf.c vsprintf.c