summaryrefslogtreecommitdiff
path: root/tune/Makefile.am
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2011-05-24 11:11:12 +0200
committerNiels Möller <nisse@lysator.liu.se>2011-05-24 11:11:12 +0200
commit85d93fbc8d96025e2478d1fdf2bcd594568361ca (patch)
treedad797a5540d9ae392bdfa85ba040cb8bc9dce91 /tune/Makefile.am
parente727b8a3d5709346027983f7c280d087c5b40686 (diff)
downloadgmp-85d93fbc8d96025e2478d1fdf2bcd594568361ca.tar.gz
Moved code for tune-gcd-p to the tune directory.
Diffstat (limited to 'tune/Makefile.am')
-rw-r--r--tune/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tune/Makefile.am b/tune/Makefile.am
index 488bb7244..c932cd3ab 100644
--- a/tune/Makefile.am
+++ b/tune/Makefile.am
@@ -68,7 +68,7 @@ $(top_builddir)/tests/libtests.la:
# program. This can always be forced with "make speed_LDFLAGS=-all-static
# ..." if desired, see tune/README.
-EXTRA_PROGRAMS = speed speed-dynamic speed-ext tuneup
+EXTRA_PROGRAMS = speed speed-dynamic speed-ext tuneup tune-gcd-p
DEPENDENCIES = libspeed.la
LDADD = $(DEPENDENCIES) $(TUNE_LIBS)
@@ -87,6 +87,10 @@ tuneup_DEPENDENCIES = $(TUNE_SQR_OBJ) libspeed.la
tuneup_LDADD = $(tuneup_DEPENDENCIES) $(TUNE_LIBS)
tuneup_LDFLAGS = $(STATIC)
+tune_gcd_p_SOURCES = tune-gcd-p.c
+tune_gcd_p_DEPENDENCIES = ../mpn/gcd.c
+tune_gcd_p_LDFLAGS = $(STATIC)
+
tune:
$(MAKE) $(AM_MAKEFLAGS) tuneup$(EXEEXT)