summaryrefslogtreecommitdiff
path: root/tune/Makefile.am
diff options
context:
space:
mode:
authorNiels M?ller <nisse@lysator.liu.se>2019-09-05 21:10:05 +0200
committerNiels M?ller <nisse@lysator.liu.se>2019-09-05 21:10:05 +0200
commit9c489cead96f7d38dd428d274805fc9cd48514fa (patch)
tree82af0b57717216c477c939c01f7f461ab043777a /tune/Makefile.am
parent95d545683e958f411d896cc9ae55507c144a063a (diff)
downloadgmp-9c489cead96f7d38dd428d274805fc9cd48514fa.tar.gz
For hgcd2, add a div1 function handling q <= 7 specially.
* mpn/generic/hgcd2.c (div1): Return both r and q as a mp_double_limb_t, replacing the DIV1 macro. (div1) [HGCD2_METHOD == 3]: New implementation handling q <= 7 specially and without branches. Based on Torbj?rn's mail to the gmp-devel list. * tune/speed.c, tune/speed.h, tune/common.c, tune/Makefile.am: Add corresponding speed support. * tune/hgcd2-3.c: New file. * tune/tuneup.c (print_define_with_speedup): New function, to output a comment with speedup compared to next-best method. (tune_hgcd2): Update tuning.
Diffstat (limited to 'tune/Makefile.am')
-rw-r--r--tune/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tune/Makefile.am b/tune/Makefile.am
index 4fa28ed12..bb107833c 100644
--- a/tune/Makefile.am
+++ b/tune/Makefile.am
@@ -58,7 +58,7 @@ libspeed_la_SOURCES = \
gcdext_single.c gcdext_double.c gcdextod.c gcdextos.c \
hgcd_lehmer.c hgcd_appr_lehmer.c hgcd_reduce_1.c hgcd_reduce_2.c \
jacbase1.c jacbase2.c jacbase3.c jacbase4.c \
- hgcd2-1.c hgcd2-2.c \
+ hgcd2-1.c hgcd2-2.c hgcd2-3.c \
mod_1_div.c mod_1_inv.c mod_1_1-1.c mod_1_1-2.c modlinv.c \
noop.c powm_mod.c powm_redc.c pre_divrem_1.c \
set_strb.c set_strs.c set_strp.c time.c