summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2010-06-08 17:19:50 +0000
committerStef Walter <stef@memberwebs.com>2010-06-08 17:19:50 +0000
commit5bf7553731217d4134d19feca0ca827b0645b445 (patch)
tree9ea3a2f8df66c4b67cf7460353dec22eea94cb2a /Makefile.am
parent730506a27cd9d34bdf5002482f7a938063e5ee03 (diff)
downloadgnome-keyring-5bf7553731217d4134d19feca0ca827b0645b445.tar.gz
Implement coverage of tests using gcov and lcov.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fb9ec480..4106ac31 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,3 +57,14 @@ dist-hook:
install-pam:
@echo "WARNING: install-pam is no longer used, use the --with-pam-dir configure option instead"
+
+if WITH_COVERAGE
+check-am:
+ $(LCOV) --directory . --zerocounters
+
+coverage: check
+ mkdir -p testing/coverage
+ $(LCOV) --directory . --capture --output-file testing/coverage.info
+ $(GENHTML) --output-directory testing/coverage testing/coverage.info
+ echo "Coverage info in: testing/coverage/index.html"
+endif \ No newline at end of file