summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2014-03-06 10:34:39 +0100
committerStef Walter <stefw@gnome.org>2014-03-06 16:46:20 +0100
commit3debf372273293ebb247a00a4e70c5ab7a399c13 (patch)
treefe84de20d6793836f2df1eda2374e7e111b7ad73 /daemon/Makefile.am
parenta909e7a5b0cf1f02d498ff6475aad4173409c3b0 (diff)
downloadgnome-keyring-3debf372273293ebb247a00a4e70c5ab7a399c13.tar.gz
daemon: Add a test of the control directory and environment variables
Combine some code for starting a test daemon into a new internal utility functions.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 68023158..bcfff8c2 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -52,3 +52,35 @@ EXTRA_DIST += \
CLEANFILES += \
$(service_DATA) \
$(desktop_DATA)
+
+# -------------------------------------------------------------------
+# TESTS
+
+noinst_LTLIBRARIES += libgkd-test.la
+
+libgkd_test_la_SOURCES = \
+ daemon/gkd-test.c \
+ daemon/gkd-test.h
+
+daemon_CFLAGS = \
+ $(DBUS_CFLAGS) \
+ $(GCR_CFLAGS)
+
+daemon_LIBS = \
+ libgkd-control-client.la \
+ libgkd-test.la \
+ libegg.la \
+ libegg-test.la \
+ $(GCR_BASE_LIBS) \
+ $(GIO_LIBS) \
+ $(GLIB_LIBS)
+
+daemon_TESTS = \
+ test-startup
+
+test_startup_SOURCES = daemon/test-startup.c
+test_startup_LDADD = $(daemon_LIBS)
+test_statrup_CFLAGS = $(daemon_CFLAGS)
+
+check_PROGRAMS += $(daemon_TESTS)
+TESTS += $(daemon_TESTS)