summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-09-19 09:06:20 +0200
committerStef Walter <stefw@collabora.co.uk>2011-09-19 09:14:27 +0200
commit3e0d0bbc831f5053dab772e44055472558306d92 (patch)
tree06e463a7bbcf4822264263250a9ec60f8e03dac7 /daemon/Makefile.am
parent8f76378a92a616ada5b588e77d75d574860bdac0 (diff)
downloadgnome-keyring-3e0d0bbc831f5053dab772e44055472558306d92.tar.gz
daemon: Don't install setuid when filesystem capabilities not avail.
The code that dropped setuid was removed in commit 66bd5dd32836a770647b8acf3476fb7922be71eb, but Makefile.am didn't match. https://bugzilla.gnome.org/show_bug.cgi?id=659402
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am11
1 files changed, 1 insertions, 10 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index f6754133..825ab4aa 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -85,15 +85,6 @@ if WITH_CAPS
install-exec-hook:
setcap cap_ipc_lock=ep $(DESTDIR)$(bindir)/gnome-keyring-daemon || true
-else # without caps
-
-# The daemon is installed as setuid so as to obtain specialized
-# capabilities, then immediately drops permissions. In other words,
-# it does *not* run as setuid.
-install-exec-hook:
- chown root $(DESTDIR)$(bindir)/gnome-keyring-daemon || true
- chmod u+s $(DESTDIR)$(bindir)/gnome-keyring-daemon || true
-
-endif # without caps
+endif
@INTLTOOL_DESKTOP_RULE@