summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2010-12-06 19:17:06 +0000
committerStef Walter <stefw@collabora.co.uk>2010-12-06 19:17:06 +0000
commitdc3e7af8a1c631fc01230208d4b5a90b243bf3b2 (patch)
tree46ea2adb4f2473f4c0bd87a2ebf1bf4919c3841d /daemon/Makefile.am
parent84f44154cdfcee219ebc4ab3b7fe5940f4c1cee4 (diff)
parent4d1f1393f839493cd4853e399a5e0db1a11cb527 (diff)
downloadgnome-keyring-dc3e7af8a1c631fc01230208d4b5a90b243bf3b2.tar.gz
Merge branch 'master' into trust-store
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 697a86c4..0122938c 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -27,6 +27,7 @@ INCLUDES= \
gnome_keyring_daemon_SOURCES = \
gkd-glue.c gkd-glue.h \
gkd-main.c gkd-main.h \
+ gkd-capability.c gkd-capability.h \
gkd-pkcs11.c gkd-pkcs11.h \
gkd-util.c gkd-util.h
@@ -79,4 +80,13 @@ CLEANFILES = \
$(service_DATA) \
$(desktop_DATA)
+# The daemon is installed as setuid so as to obtain specialized
+# capabilities, then immediately drops permissions. In other words,
+# it does *not* run as setuid.
+# If installing as non-root, chown+chmod will not succeed but
+# the build will continue.
+install-exec-hook:
+ chown root $(bindir)/gnome-keyring-daemon || true
+ chmod u+s $(bindir)/gnome-keyring-daemon || true
+
@INTLTOOL_DESKTOP_RULE@