summaryrefslogtreecommitdiff
path: root/plugins/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2019-12-12 00:03:08 +0100
committerBenjamin Berg <benjamin@sipsolutions.net>2020-07-31 08:53:12 +0000
commit4ae4f1045ca8610330d896df02ec311cf14f40d5 (patch)
tree3b1ec0e2a772c9b7f0f3f2ef75557eabd5a9c334 /plugins/meson.build
parentbf4d39342e95f373d1b84f2b8a394129bf402a36 (diff)
downloadgnome-settings-daemon-4ae4f1045ca8610330d896df02ec311cf14f40d5.tar.gz
meson: Handle common directory separately
It is not really worth it to use a loop just to set the log domain using the cflags. Explicitly name the common subdirectory rather than including it in the plugin loop.
Diffstat (limited to 'plugins/meson.build')
-rw-r--r--plugins/meson.build12
1 files changed, 9 insertions, 3 deletions
diff --git a/plugins/meson.build b/plugins/meson.build
index e3a1ac55..9ddfe69d 100644
--- a/plugins/meson.build
+++ b/plugins/meson.build
@@ -51,11 +51,17 @@ plugins_cflags = ['-DGNOME_SETTINGS_LOCALEDIR="@0@"'.format(gsd_localedir)]
enabled_plugins_file = []
-foreach plugin: [['common', '']] + enabled_plugins
+cflags = [
+ '-DG_LOG_DOMAIN="common"'
+] + plugins_cflags
+plugin_name = 'common'
+subdir('common')
+
+foreach plugin: enabled_plugins
plugin_name = plugin[0]
desktop = 'org.gnome.SettingsDaemon.@0@.desktop'.format(plugin[1])
- if plugin[1] == '' # common or dummy
+ if plugin[1] == '' # dummy
desktop_in_file = ''
else
desktop_in_file = files(join_paths(plugin_name, desktop + '.in'))
@@ -75,7 +81,7 @@ foreach plugin: enabled_plugins_file
'-DPLUGIN_DBUS_NAME="@0@"'.format(plugin_dbus_name),
] + plugins_cflags
- if not ['common', 'dummy'].contains(plugin_name)
+ if plugin_name != 'dummy'
desktop = 'org.gnome.SettingsDaemon.@0@.desktop'.format(plugin[1])
desktop_in_file = plugin[2]
user_target = 'gsd-@0@.target'.format(plugin_name)