summaryrefslogtreecommitdiff
path: root/plugins/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2020-07-15 18:08:58 +0200
committerBenjamin Berg <benjamin@sipsolutions.net>2020-07-31 08:53:12 +0000
commitc2bc1915e916c62876da6e3a54aefbf142e9ec41 (patch)
treef838352844d686a08bad8de9aba5544672cacbfd /plugins/meson.build
parente53f0f65bd9c729ffec174aeaa1dccda6e86d455 (diff)
downloadgnome-settings-daemon-c2bc1915e916c62876da6e3a54aefbf142e9ec41.tar.gz
xsettings: Order after x11 services and before X11 services ready flag
We need to both reliably shutdown and notify gnome-shell that we are ready. The gnome-session-x11-services.target does the first (we order ourselves After= to ensure this works) and the -ready.target is our flag to tell gnome-shell it may release the X11 socket for clients.
Diffstat (limited to 'plugins/meson.build')
-rw-r--r--plugins/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/plugins/meson.build b/plugins/meson.build
index ff104e74..ba34f70d 100644
--- a/plugins/meson.build
+++ b/plugins/meson.build
@@ -46,7 +46,11 @@ endif
# Specify futher required units, 'before' or 'after' may be specified if ordering is needed
plugin_gate_units = {
- 'xsettings': [['gnome-session-x11-services.target', 'before']],
+ 'xsettings': [
+ # Both after/before. after for stopping reliably, before for synchronisation
+ ['gnome-session-x11-services.target', 'after'],
+ ['gnome-session-x11-services-ready.target', 'before'],
+ ],
# 'wacom': [['wacom.target']],
# 'smartcard': [['smartcard.target']],
}