summaryrefslogtreecommitdiff
path: root/plugins/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-02-01 08:35:23 +0100
committerBastien Nocera <hadess@hadess.net>2018-02-05 17:42:49 +0100
commitf180fc7cd655d29d6fdae7e71e2cb6bc8672e823 (patch)
treec7552bdd1780262b13f4458cbbff1302b6016c0a /plugins/meson.build
parent8351ff4d451da2004efc36a205e369b3207ecfe6 (diff)
downloadgnome-settings-daemon-f180fc7cd655d29d6fdae7e71e2cb6bc8672e823.tar.gz
build: Port to meson build system
meson is a build system focused on speed an ease of use, which helps speeding up the software development. This patch adds meson support along autotools. https://bugzilla.gnome.org/show_bug.cgi?id=793087
Diffstat (limited to 'plugins/meson.build')
-rw-r--r--plugins/meson.build48
1 files changed, 48 insertions, 0 deletions
diff --git a/plugins/meson.build b/plugins/meson.build
new file mode 100644
index 00000000..6babd8ec
--- /dev/null
+++ b/plugins/meson.build
@@ -0,0 +1,48 @@
+enabled_plugins = [
+ 'a11y-settings',
+ 'clipboard',
+ 'color',
+ 'datetime',
+ 'dummy',
+ 'power',
+ 'housekeeping',
+ 'keyboard',
+ 'media-keys',
+ 'mouse',
+ 'screensaver-proxy',
+ 'sharing',
+ 'sound',
+ 'xsettings'
+]
+
+if enable_smartcard
+ enabled_plugins += ['smartcard']
+endif
+
+if enable_wacom
+ enabled_plugins += ['wacom']
+endif
+
+if enable_cups
+ enabled_plugins += ['print-notifications']
+endif
+
+if enable_rfkill
+ enabled_plugins += ['rfkill']
+endif
+
+plugins_conf = configuration_data()
+plugins_conf.set('libexecdir', gsd_libexecdir)
+
+plugins_deps = [libgsd_dep]
+
+plugins_cflags = ['-DGNOME_SETTINGS_LOCALEDIR="@0@"'.format(gsd_localedir)]
+
+foreach plugin_name: ['common'] + enabled_plugins
+ cflags = [
+ '-DG_LOG_DOMAIN="@0@-plugin"'.format(plugin_name),
+ '-DPLUGIN_NAME="@0@"'.format(plugin_name),
+ ] + plugins_cflags
+
+ subdir(plugin_name)
+endforeach