summaryrefslogtreecommitdiff
path: root/themes/HighContrast/icons/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'themes/HighContrast/icons/Makefile.am')
-rw-r--r--themes/HighContrast/icons/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/themes/HighContrast/icons/Makefile.am b/themes/HighContrast/icons/Makefile.am
index 76e824d0..5545157e 100644
--- a/themes/HighContrast/icons/Makefile.am
+++ b/themes/HighContrast/icons/Makefile.am
@@ -6,7 +6,7 @@ render_sizes = "16x16" "22x22" "24x24" "32x32" "48x48" "256x256" "scalable"
THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$$size/* -type d`; do printf "$$dir,"; done; done;)
%.theme: %.theme.in Makefile
- dirs="`echo $(THEME_DIRS) | sed -e 's#\./##g'`"; \
+ dirs="`echo $(THEME_DIRS) | sed -e \"s#$(srcdir)/*##g\"`"; \
sed -e "s|\@THEME_DIRS\@|$$dirs|g" < $< > $@; \
echo "" >> $@; \
for dir in `echo $$dirs | sed -e "s/,/ /g"`; do \